服务支持

cve

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202108-0009

摘要:exiv2安全漏洞 安全等级:中等 公告ID:KYSA-202108-0009 发布日期:2021-11-16 影响CVE:CVE-2021-34334、CVE-2021-37616、CVE-2021-37622、CVE-2021-37620、CVE-2021-32815、CVE-2021-32617、CVE-2021-29473、CVE-2021-29457、CVE-2021-29458等

详细介绍

1. 修复的CVE信息

  • CVE-2021-34334

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2中存在安全漏洞,攻击者可利用该漏洞导致拒绝服务。

  • CVE-2021-37616

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2中存在安全漏洞,攻击者可利用该漏洞导致拒绝服务。

  • CVE-2021-37622

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 0.27.4之前版本存在安全漏洞,该漏洞源于软件中的一个无限循环。当使用Exiv2修改映像文件的元数据时,将触发无限循环。攻击者可利用该漏洞诱骗受害者在一个特制的图像文件上运行Exiv2,那么攻击者可能会利用该漏洞导致拒绝服务

  • CVE-2021-37620

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 中存在缓冲区错误漏洞,该漏洞源于产品在读取图片元数据时未能验证数据边界,攻击者可通过特殊的图像文件引发越界读操作进而导致拒绝服务。以下产品及版本受到影响:Exiv2 v0.27.4 版本及之前版本。

  • CVE-2021-32815

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2存在安全漏洞,该漏洞用于读取、写入、删除和修改映像文件的元数据。当使用Exiv2修改精心制作的映像文件的元数据时,会触发断言失败。如果攻击者可利用该漏洞可以诱骗受害者在一个精心制作的图像文件上运行Exiv2,那么攻击者可利用该漏洞可能会利用该漏洞导致拒绝服务。

  • CVE-2021-32617

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 v0.27.3版本及之前版本存在资源管理错误漏洞,攻击者可利用该漏洞导致拒绝服务。

  • CVE-2021-29473

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 存在缓冲区错误漏洞,攻击者可利用该漏洞通过破坏Exiv2来导致拒绝服务。

  • CVE-2021-29457

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 存在安全漏洞,攻击者可利用该漏洞可能会利用该漏洞来获得代码执行。

  • CVE-2021-29458

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 存在安全漏洞,攻击者可利用该漏洞可能会利用该漏洞导致Exiv2崩溃,从而导致拒绝服务。

  • CVE-2021-3482

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2中存在输入验证错误漏洞。该漏洞源于jp2image.cpp中的Jp2Image :: readMetadata()中的rawData.size属性不正确的检查会导致基于堆的缓冲区溢出。

  • CVE-2021-34335

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 0.27.4之前版本存在数字错误漏洞,该漏洞源于软件中发现了一个浮点异常,该异常是由整数除零引起的。当使用Exiv2打印图像文件的元数据时,会触发浮点异常。攻击者可利用该漏洞诱骗受害者在一个特制的图像文件上运行Exiv2,那么攻击者可能会利用该漏洞导致拒绝服务。

  • CVE-2021-37615

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 0.27.4之前版本存在代码问题漏洞,该漏洞源于软件中发现了空指针解引用。当使用Exiv2打印特制的图像文件的元数据时,会触发空指针解引用。攻击者可利用该漏洞可以诱骗受害者在一个特制的图像文件上运行Exiv2,那么攻击者可能会利用该漏洞导致拒绝服务。

  • CVE-2021-37616

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 中存在代码问题漏洞,该漏洞源于产品在打印图片文件时未能检查指针有效性,攻击者可通过特殊的图像文件引发空指针引用进而导致拒绝服务。以下产品及版本受到影响:Exiv2 v0.27.4 版本及之前版本。

  • CVE-2021-37618

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 中存在缓冲区错误漏洞,该漏洞源于产品在打印图片文件时未能验证数据边界,攻击者可通过特殊的图像文件引发越界读操作进而导致拒绝服务。以下产品及版本受到影响:Exiv2 v0.27.4 版本及之前版本。

  • CVE-2021-37619

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 中存在缓冲区错误漏洞,该漏洞源于产品在写入图片元数据时未能验证数据边界,攻击者可通过特殊的图像文件引发越界读操作进而导致拒绝服务。以下产品及版本受到影响:Exiv2 v0.27.4 版本及之前版本。

  • CVE-2021-37621

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 中存在处理逻辑错误漏洞,该漏洞源于产品在打印图片时处理逻辑存在漏洞从而引发无限循环。攻击者可通过该漏洞导致拒绝服务。以下产品及版本受到影响:Exiv2 v0.27.4 版本及之前版本。

  • CVE-2021-37623

    Exiv2是Andreas Huggel个人开发者的一套用于管理图像元数据的C++库和命令行应用程序。该产品提供了读取和写入EXIF、IPTC和XMP等多种格式图像元数据的功能。Exiv2 0.27.4及之前版本存在安全漏洞,攻击者可利用该漏洞导致拒绝服务。


2. 影响的操作系统

银河麒麟桌面操作系统V4 SP1

银河麒麟桌面操作系统V4 SP2

银河麒麟桌面操作系统V4 SP3

银河麒麟桌面操作系统V4 SP4

银河麒麟桌面操作系统V10

银河麒麟服务器操作系统V4 SP1

银河麒麟服务器操作系统V4 SP2

银河麒麟服务器操作系统V4 SP3

银河麒麟服务器操作系统V4 SP4

银河麒麟桌面操作系统V10专业版


3. 修复版本

软件包:exiv2

0.25-2.1kord16.04.7+esm4(V4、V10)

0.27.2-8kylin2.6(V10专业版)


4. 受影响的软件包

  • 银河麒麟桌面操作系统V4

exiv2

libexiv2-14

libexiv2-dbg

libexiv2-dev

libexiv2-doc

  • 银河麒麟桌面操作系统V10

exiv2

libexiv2-14

libexiv2-dbg

libexiv2-dev

libexiv2-doc

  • 银河麒麟桌面操作系统V10专业版

exiv2

libexiv2-27

libexiv2-dev

libexiv2-doc


5. 修复方法

方法一:配置源进行升级安装

打开软件包源配置文件,根据仓库地址进行修改。

4.0.2-sp1:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp1-desktop main restricted universe multiverse

4.0.2-sp2:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp2-desktop main restricted universe multiverse

4.0.2-sp3:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp3-desktop main restricted universe multiverse

4.0.2-sp4:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp4-desktop main restricted universe multiverse

10.0:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.0 main restricted universe multiverse

10.0 SP1:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.1 main restricted universe multiverse

配置完成后执行更新命令进行升级。$sudo apt update

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。$dpkg -i Packagelists


6. 软件包下载地址

 


上一篇: KYSA-202108-0008 下一篇: KYSA-202108-0010

试用

服务

动态

联系