服务支持

cve

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202109-0014

摘要:cpio安全漏洞 安全等级:中等 公告ID:KYSA-202109-0014 发布日期:2021-11-22 影响CVE:CVE-2021-38185

详细介绍

1. 修复的CVE信息

  • CVE-2021-38185

    cpio是一款用于类UNIX系统的文件备份程序。cpio 中存在安全漏洞。允许攻击者通过精心设计的模式文件执行任意代码,因为 dstring.c ds_fgetstr 整数溢出会触发越界堆写入。


2. 影响的操作系统

银河麒麟桌面操作系统V10专业版


3. 修复版本

软件包:cpio

2.13+dfsg-2kylin0.3(V10专业版)


4. 受影响的软件包

  • 银河麒麟桌面操作系统V10专业版

cpio

cpio-win32


5. 修复方法

方法一:配置源进行升级安装

打开软件包源配置文件,根据仓库地址进行修改。

4.0.2-sp1:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp1-desktop main restricted universe multiverse

4.0.2-sp2:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp2-desktop main restricted universe multiverse

4.0.2-sp3:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp3-desktop main restricted universe multiverse

4.0.2-sp4:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp4-desktop main restricted universe multiverse

10.0:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.0 main restricted universe multiverse

10.0 SP1:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.1 main restricted universe multiverse

配置完成后执行更新命令进行升级。$sudo apt update

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。$dpkg -i Packagelists


6. 软件包下载地址

 

 





上一篇: KYSA-202107-0015 下一篇: KYSA-202109-0015

试用

服务

动态

联系