服务支持

cve

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202110-0009

摘要:containerd安全漏洞 安全等级:重要 公告ID:KYSA-202110-0009 发布日期:2021-11-22 影响CVE:CVE-2021-41103

详细介绍

1. 修复的CVE信息

  • CVE-2021-41103

    containerd是美国阿帕奇(Apache)基金会的一个容器守护进程。该进程根据 RunC OCI 规范负责控制宿主机上容器的完整周期。containerd 存在路径遍历漏洞,该漏洞源于容器根目录和一些插件的权限没有受到足够的限制。攻击者可利用该漏洞使得没有特权的Linux用户可以遍历目录内容和执行程序。


2. 影响的操作系统

银河麒麟桌面操作系统V10专业版


3. 修复版本

软件包:containerd

1.5.2-0kylin1~20.04.3(V10专业版)


4. 受影响的软件包

  • 银河麒麟桌面操作系统V10专业版

containerd

golang-github-containerd-containerd-dev

golang-github-docker-containerd-dev


5. 修复方法

方法一:配置源进行升级安装

打开软件包源配置文件,根据仓库地址进行修改。

4.0.2-sp1:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp1-desktop main restricted universe multiverse

4.0.2-sp2:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp2-desktop main restricted universe multiverse

4.0.2-sp3:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp3-desktop main restricted universe multiverse

4.0.2-sp4:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp4-desktop main restricted universe multiverse

10.0:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.0 main restricted universe multiverse

10.0 SP1:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.1 main restricted universe multiverse

配置完成后执行更新命令进行升级。$sudo apt update

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。$dpkg -i Packagelists


6. 软件包下载地址

 

 

 


上一篇: KYSA-202109-0015 下一篇: KYSA-202110-0011

试用

服务

动态

联系