服务支持

cve

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202111-0004

摘要:postgresql-12安全漏洞 安全等级:中等 公告ID:KYSA-202111-0004 发布日期:2021-11-22 影响CVE:CVE-2021-23222、CVE-2021-23214

详细介绍

1. 修复的CVE信息

  • CVE-2021-23222

    PostgreSQL是Postgresql组织的一套自由的对象关系型数据库管理系统。该系统支持大部分SQL标准并且提供了许多其他特性,例如外键、触发器、视图等。PostgreSQL 存在安全漏洞,该漏洞源于PostgreSQL中的libpq进程处理加密连接的方式造成的。攻击者可利用该漏洞窃取可能在会话早期传输的客户端密码或其他机密数据。

  • CVE-2021-23214

    PostgreSQL是Postgresql组织的一套自由的对象关系型数据库管理系统。该系统支持大部分SQL标准并且提供了许多其他特性,例如外键、触发器、视图等。PostgreSQL 存在安全漏洞,该漏洞源于PostgreSQL处理加密连接的方式造成的。攻击者可利用该漏洞执行MitM攻击。


2. 影响的操作系统

银河麒麟桌面操作系统V10专业版


3. 修复版本

软件包:strongswan

12.9-0kylin0.20.04.1(V10专业版)


4. 受影响的软件包

  • 银河麒麟桌面操作系统V10专业版

libecpg-compat3

libecpg-dev

libecpg6

libpgtypes3

libpq-dev

libpq5

postgresql-12

postgresql-client-12

postgresql-doc-12

postgresql-plperl-12

postgresql-plpython3-12

postgresql-pltcl-12

postgresql-server-dev-12


5. 修复方法

方法一:配置源进行升级安装

打开软件包源配置文件,根据仓库地址进行修改。

4.0.2-sp1:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp1-desktop main restricted universe multiverse

4.0.2-sp2:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp2-desktop main restricted universe multiverse

4.0.2-sp3:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp3-desktop main restricted universe multiverse

4.0.2-sp4:http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp4-desktop main restricted universe multiverse

10.0:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.0 main restricted universe multiverse

10.0 SP1:http://archive.kylinos.cn/kylin/KYLIN-ALL 10.1 main restricted universe multiverse

配置完成后执行更新命令进行升级。$sudo apt update

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。$dpkg -i Packagelists


6. 软件包下载地址

  • 麒麟操作系统桌面版V10专业版

    X86_64软件包下载地址:

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg6_12.9-0kylin0.20.04.1_amd64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpq-dev_12.9-0kylin0.20.04.1_amd64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpgtypes3_12.9-0kylin0.20.04.1_amd64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg-dev_12.9-0kylin0.20.04.1_amd64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpq5_12.9-0kylin0.20.04.1_amd64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg-compat3_12.9-0kylin0.20.04.1_amd64.deb

arm64软件包下载地址:

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg6_12.9-0kylin0.20.04.1_arm64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpq-dev_12.9-0kylin0.20.04.1_arm64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpgtypes3_12.9-0kylin0.20.04.1_arm64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg-dev_12.9-0kylin0.20.04.1_arm64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpq5_12.9-0kylin0.20.04.1_arm64.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg-compat3_12.9-0kylin0.20.04.1_arm64.deb

mips64el软件包下载地址:

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg6_12.9-0kylin0.20.04.1_mips64el.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpq-dev_12.9-0kylin0.20.04.1_mips64el.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpgtypes3_12.9-0kylin0.20.04.1_mips64el.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg-dev_12.9-0kylin0.20.04.1_mips64el.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libpq5_12.9-0kylin0.20.04.1_mips64el.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/main/p/postgresql-12/libecpg-compat3_12.9-0kylin0.20.04.1_mips64el.deb

 

 


上一篇: KYSA-202111-0003 下一篇: 没有了

试用

服务

动态

联系