服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202103-1002

摘要:python3漏洞 安全等级:中等 公告ID:KYSA-202103-1002 发布日期:2021-03-06 影响CVE:CVE-2021-3177、CVE-2020-27619

详细介绍

1. 修复的CVE信息

  • CVE-2021-3177

    描述:Python是Python基金会的一套开源的、面向对象的程序设计语言。该语言具有可扩展、支持模块和包、支持多种平台等特点。 Python 3.x through 3.9.1 存在缓冲区错误漏洞,该漏洞源于PyCArg_repr in_ctypes/callproc.c,攻击者可利用该漏洞执行远程代码。

  • CVE-2020-27619

    描述:Python是Python软件基金会的一套开源的、面向对象的程序设计语言。该语言具有可扩展、支持模块和包、支持多种平台等特点。 Python 3 3.9版本存在安全漏洞,该漏洞源于Lib/test/multibytecodec_support.py CJK编辑器测试对通过HTTP检索的内容调用eval()函数。


2. 受影响的操作系统

  • 银河麒麟高级服务器操作系统V10(SP1)


3. 修复版本

python3-3.7.9-6


4. 受影响的软件包

  • 银河麒麟高级服务器操作系统V10(SP1)

    aarch64: python3

    x86_64: python3


5.修复方法

方法一:配置源进行升级安装

     1)打开软件包源配置文件,根据仓库地址进行修改。

          银河麒麟高级服务器操作系统V10(SP1)

          仓库源地址:x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10SP1/os/adv/lic/updates/x86_64/

                                aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10SP1/os/adv/lic/updates/aarch64/

     2)配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename


6. 软件包下载地址





上一篇: KYSA-202103-1001 下一篇: KYSA-202103-1003

试用

服务

动态

联系