服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202103-1006

摘要:dnsmasq漏洞 安全等级:中等 公告ID:KYSA-202103-1006 发布日期:2021-03-19 影响CVE:CVE-2020-25684、CVE-2020-25685、CVE-2020-25686

详细介绍

1. 修复的CVE信息

  • CVE-2020-25684

    描述:Dnsmasq是一款使用C语言编写的轻量级DNS转发和DHCP、TFTP服务器。dnsmasq 2.83版本之前存在安全漏洞,攻击者可以利用该漏洞执行DNS缓存中毒攻击。

  • CVE-2020-25685

    描述:Dnsmasq是一款使用C语言编写的轻量级DNS转发和DHCP、TFTP服务器。Dnsmasq 存在安全漏洞,该漏洞源于在没有dnnssec的情况下编译时使用弱哈希算法(CRC32)来验证DNS响应。

  • CVE-2020-25686

    描述:Dnsmasq是一款使用C语言编写的轻量级DNS转发和DHCP、TFTP服务器。Dnsmasq 存在安全特征问题漏洞,该漏洞源于不会检查现有的同名待处理请求,并转发一个新的请求,从而允许攻击者执行一个“生日攻击”场景来伪造应答,并可能破坏DNS缓存。


2. 受影响的操作系统

  • 中标麒麟高级服务器操作系统 V7

  • 银河麒麟高级服务器操作系统V10


3. 修复版本

dnsmasq-2.76-16.el7_9.1


4. 受影响的软件包

  • 中标麒麟高级服务器操作系统 V7

    aarch64: dnsmasq

    x86_64: dnsmasq

  • 银河麒麟高级服务器操作系统V10

    aarch64: dnsmasq

    x86_64: dnsmasq


5.修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

中标麒麟高级服务器操作系统V7:

x86_64:http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/x86_64/

aarch64:http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/aarch64/

银河麒麟高级服务器操作系统V10:

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/x86_64/

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/aarch64/

2.配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename


6. 软件包下载地址


上一篇: KYSA-202103-1005 下一篇: KYSA-202103-1007

试用

服务

动态

联系