服务支持

support

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202102-0014

摘要:junit4漏洞 安全等级:中等 公告ID:KYSA-202102-0014 发布日期:2021-04-07 影响CVE:CVE-2020-15250

详细介绍

1. 修复的CVE信息

  • CVE-2020-15250

    描述:Junit是个人开发者的一个开放源代码的Java测试框架。JUnit4 4.13.1之前版本存在信息泄露漏洞,该漏洞源于测试规则TemporaryFolder包含一个本地信息泄露漏洞。在类似Unix的系统中,系统的临时目录在该系统上的所有用户之间共享。因此,在将文件和目录写入此目录时,默认情况下,相同系统上的其他用户都可以读取它们。此漏洞不允许其他用户覆盖这些目录或文件的内容。这纯粹是一个信息披露的漏洞。如果JUnit测试编写了敏感信息,这个漏洞就会对您造成影响。


2. 受影响的操作系统

  • 银河麒麟桌面操作系统V4 SP1

  • 银河麒麟桌面操作系统V4 SP2

  • 银河麒麟桌面操作系统V4 SP3

  • 银河麒麟桌面操作系统V4 SP4

  • 银河麒麟桌面操作系统V10

  • 银河麒麟桌面操作系统V10 SP1

  • 银河麒麟服务器操作系统V4 SP1

  • 银河麒麟服务器操作系统V4 SP2

  • 银河麒麟服务器操作系统V4 SP3

  • 银河麒麟服务器操作系统V4 SP4


3. 修复版本

  • 软件包:junit4

junit4-4.12-4kord1.1(V4、V10)

junit4-doc - 4.12-4kord1.1(V4、V10)

junit4-4.12-8kylin0.20.04.1(V10 SP1)

junit4-doc-4.12-8kylin0.20.04.1(V10 SP1)


4. 受影响的软件包

  • 银河麒麟桌面操作系统V4桌面版

    junit4

    junit4-doc

  • 银河麒麟桌面操作系统V10桌面版

    junit4

    junit4-doc

  • 银河麒麟桌面操作系统V10 SP1

    junit4

    junit4-doc


5.修复方法

方法一:配置源进行升级安装

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。     $dpkg -i Packagelists


6. 软件包下载地址



上一篇: KYSA-202102-0022 下一篇: KYSA-202102-0019

试用

服务

动态

联系