服务支持

support

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202102-0019

摘要:openssl漏洞 安全等级:中等 公告ID:KYSA-202102-0019 发布日期:2021-04-07 影响CVE:CVE-2021-23841、CVE-2021-23840

详细介绍

1. 修复的CVE信息

  • CVE-2021-23841

    描述:OpenSSL是Openssl团队的一个开源的能够实现安全套接层(SSLv2/v3)和安全传输层(TLSv1)协议的通用加密库。该产品支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。OpenSSL public API 存在输入验证错误漏洞,该漏洞源于X509_issuer_and_serial_hash函数不能正确处理解析issuer字段时可能发生的任何错误。

  • CVE-2021-23840

    描述:OpenSSL是Openssl团队的一个开源的能够实现安全套接层(SSLv2/v3)和安全传输层(TLSv1)协议的通用加密库。该产品支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。OpenSSL 存在安全漏洞,攻击者可利用该漏洞导致应用程序行为不正确或崩溃。


2. 受影响的操作系统

  • 银河麒麟桌面操作系统V4 SP1

  • 银河麒麟桌面操作系统V4 SP2

  • 银河麒麟桌面操作系统V4 SP3

  • 银河麒麟桌面操作系统V4 SP4

  • 银河麒麟桌面操作系统V10

  • 银河麒麟桌面操作系统V10 SP1

  • 银河麒麟服务器操作系统V4 SP1

  • 银河麒麟服务器操作系统V4 SP2

  • 银河麒麟服务器操作系统V4 SP3

  • 银河麒麟服务器操作系统V4 SP4


3. 修复版本

软件包:openssl

libssl1.0.0-1.0.2g-1kord4.19(V4、V10)

libssl1.1-1.1.1f-1kylin2.2(V10 SP1)


4. 受影响的软件包

  • 银河麒麟桌面操作系统V4桌面版

libcrypto1.0.0-udeb

libssl-dev

libssl-doc

libssl1.0.0-dbg

libssl1.0.0-udeb

libssl1.0.0

openssl

  • 银河麒麟桌面操作系统V10桌面版

libcrypto1.0.0-udeb

libssl-dev

libssl-doc

libssl1.0.0-dbg

libssl1.0.0-udeb

libssl1.0.0

openssl

  • 银河麒麟桌面操作系统V10 SP1

libssl-dev

libssl-doc

libssl1.1

openssl


5.修复方法

方法一:配置源进行升级安装


方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。

$dpkg -i Packagelists


6. 软件包下载地址




上一篇: KYSA-202102-0014 下一篇: KYSA-202102-0027

试用

服务

动态

联系