服务支持

support

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202102-0031

摘要:tiff漏洞 安全等级:中等 公告ID:KYSA-202102-0031 发布日期:2021-04-07 影响CVE:CVE-2020-35524、CVE-2020-35523

详细介绍

1. 修复的CVE信息

  • CVE-2020-35524

    描述:Silicon Graphics LibTIFF是美国Silicon Graphics公司的一个读写TIFF(标签图像文件格式)文件的库。该库包含一些处理TIFF文件的命令行工具。LibTIFF 存在缓冲区错误漏洞,攻击者可利用该漏洞通过t2p read tiff size()触发缓冲区溢出,从而触发拒绝服务,并可能运行代码。

  • CVE-2020-35523

    描述:Silicon Graphics LibTIFF是美国Silicon Graphics公司的一个读写TIFF(标签图像文件格式)文件的库。该库包含一些处理TIFF文件的命令行工具。LibTIFF 存在输入验证错误漏洞,攻击者可利用该漏洞通过LibTIFF的gtTileContig()触发缓冲区溢出,从而触发拒绝服务,并可能运行代码。


2. 受影响的操作系统

  • 银河麒麟桌面操作系统V4 SP1

  • 银河麒麟桌面操作系统V4 SP2

  • 银河麒麟桌面操作系统V4 SP3

  • 银河麒麟桌面操作系统V4 SP4

  • 银河麒麟桌面操作系统V10

  • 银河麒麟桌面操作系统V10 SP1

  • 银河麒麟服务器操作系统V4 SP1

  • 银河麒麟服务器操作系统V4 SP2

  • 银河麒麟服务器操作系统V4 SP3

  • 银河麒麟服务器操作系统V4 SP4


3. 修复版本

软件包:tiff

libtiff5 - 4.0.6-1kord0.8(V4、V10)

libtiff-tools - 4.0.6-1kord0.8(V4、V10)

libtiff5 - 4.1.0+git191117-2kylin0.20.04.1(V10 SP1)

libtiff-tools - 4.1.0+git191117-2kylin0.20.04.1(V10 SP1)


4. 受影响的软件包

  • 银河麒麟桌面操作系统V4桌面版

libtiff-doc

libtiff-opengl

libtiff-tools

libtiff5-dev

libtiff5

libtiffxx5

  • 银河麒麟桌面操作系统V10桌面版

libtiff-doc

libtiff-opengl

libtiff-tools

libtiff5-dev

libtiff5

libtiffxx5

  • 银河麒麟桌面操作系统V10 SP1

libtiff-dev

libtiff-doc

libtiff-opengl

libtiff-tools

libtiff5-dev

libtiff5

libtiffxx5


5.修复方法

方法一:配置源进行升级安装

打开软件包源配置文件,根据仓库地址进行修改。

4.0.2-sp1: http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp1-desktop main restricted universe multiverse

4.0.2-sp2: http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp2-desktop main restricted universe multiverse

4.0.2-sp3: http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp3-desktop main restricted universe multiverse

4.0.2-sp4: http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp4-desktop main restricted universe multiverse

10.0: http://archive.kylinos.cn/kylin/KYLIN-ALL 10.0 main restricted universe multiverse

10.0 SP1http://archive.kylinos.cn/kylin/KYLIN-ALL 10.1 main restricted universe multiverse

配置完成后执行更新命令进行升级    $sudo apt update


方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。   $dpkg -i Packagelists


6. 软件包下载地址



上一篇: KYSA-202102-0028 下一篇: KYSA-202103-0016

试用

服务

动态

联系