服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202105-1006

摘要:dbus漏洞 安全等级:重要 公告ID:KYSA-202105-1006 发布日期:2021-05-21 影响CVE:CVE-2020-35512、CVE-2020-12049

详细介绍

1. 修复的CVE信息

  • CVE-2020-35512

    描述:D-BUS是一种消息总线系统,它主要用于进程间通信及远程过程调用等。该漏洞导致崩溃或其他未定义的行为。

  • CVE-2020-12049

    描述:D-BUS是一种消息总线系统,它主要用于进程间通信及远程过程调用等。该漏洞源于dbus-daemon中使用的libdbus的DBusServer,在消息超过每个消息文件描述符限制时会泄漏文件描述符。本地攻击者可利用该漏洞使系统服务达到其文件描述符限制,从而无法为后续D-Bus客户端提供服务。


2. 受影响的操作系统

  • 银河麒麟高级服务器操作系统V10(SP1)


3. 修复版本

dbus-1.12.16-16.ky10


4. 受影响的软件包

  • 银河麒麟高级服务器操作系统V10(SP1)

aarch64: dbus

x86_64: dbus


5.修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

银河麒麟高级服务器操作系统V10(SP1)

仓库源地址:

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/

2.配置完成后执行更新命令进行升级,命令如下: yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下: yum install Packagename


6. 软件包下载地址

  • 银河麒麟高级服务器操作系统V10(SP1)

dbus x86_64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/Packages/dbus-1.12.16-16.ky10.x86_64.rpm

dbus aarch64软件包下载地址: 

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/Packages/dbus-1.12.16-16.ky10.aarch64.rpm

注:其他相关依赖包请到相同目录下载

 

 




上一篇: KYSA-202105-1005 下一篇: KYSA-202105-1007

试用

服务

动态

联系