服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202105-1008

摘要:python3漏洞 安全等级:中等 公告ID:KYSA-202105-1008 发布日期:2021-05-28 影响CVE:CVE-2019-20907、CVE-2020-14422

详细介绍

1. 修复的CVE信息

  • CVE-2019-20907

    描述:Python是Python软件基金会的一套开源的、面向对象的程序设计语言。该漏洞源于_proc_pax缺少标头验证。攻击者可借助TAR归档文件利用该漏洞导致无限循环。

  • CVE-2020-14422

    描述:Python是Python软件基金会的一套开源的、面向对象的程序设计语言。该漏洞源于程序未正确计算哈希值。远程攻击者可利用该漏洞造成拒绝服务或创建许多字典条目。


2. 受影响的操作系统

  • 中标麒麟高级服务器操作系统 V7

  • 银河麒麟高级服务器操作系统V10


3. 修复版本

python3-3.6.8-18.el7


4. 受影响的软件包

  • 中标麒麟高级服务器操作系统 V7

    x86_64: python3

    aarch64: python3

  • 银河麒麟高级服务器操作系统V10

    x86_64: python3

    aarch64: python3


5.修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

中标麒麟高级服务器操作系统V7:

x86_64:http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/x86_64/

aarch64:http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/aarch64/

银河麒麟高级服务器操作系统V10:

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/x86_64/

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/aarch64/

2.配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename


6. 软件包下载地址

  • 中标麒麟高级服务器操作系统V7

python3 x86_64软件包下载地址: 

http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/x86_64/Packages/python3-3.6.8-18.el7.x86_64.rpm

python3 aarch64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V7/V7Update9/os/adv/lic/updates/aarch64/Packages/python3-3.6.8-18.el7.aarch64.rpm

注:其他相关依赖包请到相同目录下载

  • 银河麒麟高级服务器操作系统V10

python3 x86_64软件包下载地址: 

http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/x86_64/Packages/python3-3.6.8-18.el7.x86_64.rpm

python3 aarch64软件包下载地址: 

http://update.cs2c.com.cn:8080/NS/V10/V10-ZJ/os/adv/lic/updates/aarch64/Packages/python3-3.6.8-18.el7.aarch64.rpm

注:其他相关依赖包请到相同目录下载




上一篇: KYSA-202105-1007 下一篇: KYSA-202105-1009

试用

服务

动态

联系