服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202109-1009

摘要:avahi漏洞 安全等级:中等 公告ID:KYSA-202109-1009 发布日期:2021-09-03 影响CVE:CVE-2021-36217

详细介绍

1. 修复的CVE信息

  • CVE-2021-36217

    描述:Avahi 0.8 允许通过 D-Bus 接口或“ping .local”命令对 avahi-daemon 进行本地拒绝服务(空指针取消引用和守护程序崩溃)。


2. 影响的操作系统及修复版本

  • 银河麒麟高级服务器操作系统 V10 SP2

avahi-0.8-5.ky10

avahi-compat-howl-0.8-5.ky10

avahi-compat-howl-devel-0.8-5.ky10

avahi-compat-libdns_sd-0.8-5.ky10

avahi-compat-libdns_sd-devel-0.8-5.ky10

avahi-debugsource-0.8-5.ky10

avahi-devel-0.8-5.ky10

avahi-dnsconfd-0.8-5.ky10

avahi-glib-0.8-5.ky10

avahi-gobject-0.8-5.ky10

avahi-help-0.8-5.ky10

avahi-libs-0.8-5.ky10

avahi-tools-0.8-5.ky10

avahi-ui-0.8-5.ky10

avahi-ui-devel-0.8-5.ky10

avahi-ui-gtk3-0.8-5.ky10


3. 受影响的软件包

  • 银河麒麟高级服务器操作系统 V10 SP2

    aarch64:avahi、avahi-compat-howl、avahi-compat-howl-devel、avahi-compat-libdns_sd、avahi-compat-libdns_sd-devel、avahi-debugsource、avahi-devel、avahi-dnsconfd、avahi-glib、avahi-gobject、avahi-help、avahi-libs、avahi-tools、avahi-ui、avahi-ui-devel、avahi-ui-gtk3

    x86_64:avahi、avahi-compat-howl、avahi-compat-howl-devel、avahi-compat-libdns_sd、avahi-compat-libdns_sd-devel、avahi-debugsource、avahi-devel、avahi-dnsconfd、avahi-glib、avahi-gobject、avahi-help、avahi-libs、avahi-tools、avahi-ui、avahi-ui-devel、avahi-ui-gtk3


4. 修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:银河麒麟高级服务器操作系统 V10 SP2

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/

2.配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename


5. 软件包下载地址

  • 银河麒麟高级服务器操作系统 V10 SP2

 avahi aarch64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-compat-howl-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-compat-howl-devel-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-compat-libdns_sd-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-compat-libdns_sd-devel-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-debugsource-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-devel-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-dnsconfd-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-glib-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-gobject-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-help-0.8-5.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-libs-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-tools-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-ui-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-ui-devel-0.8-5.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/avahi-ui-gtk3-0.8-5.ky10.aarch64.rpm

 avahi x86_64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-compat-howl-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-compat-howl-devel-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-compat-libdns_sd-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-compat-libdns_sd-devel-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-debugsource-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-devel-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-dnsconfd-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-glib-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-gobject-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-help-0.8-5.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-libs-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-tools-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-ui-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-ui-devel-0.8-5.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/avahi-ui-gtk3-0.8-5.ky10.x86_64.rpm

注:其他相关依赖包请到相同目录下载

 


上一篇: KYSA-202109-1008 下一篇: KYSA-202109-1010

试用

服务

动态

联系