服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202109-1012

摘要:ant漏洞 安全等级:低等 公告ID:KYSA-202109-1012 发布日期:2021-09-03 影响CVE:CVE-2021-36373、CVE-2021-36374

详细介绍

1. 修复的CVE信息

  • CVE-2021-36373

    描述:在读取特制的 TAR 存档时,可以进行 Apache Ant 构建以分配大量内存,最终导致内存不足错误,即使是小输入也是如此。这可用于中断使用 Apache Ant 的构建。 1.9.16 和 1.10.11 之前的 Apache Ant 受到影响。

  • CVE-2021-36374

    描述:在读取特制的 ZIP 存档或派生格式时,可以进行 Apache Ant 构建以分配大量内存,从而导致内存不足错误,即使是小输入也是如此。这可用于中断使用 Apache Ant 的构建。 ZIP 档案中常用的派生格式是例如 JAR 文件和许多办公文件。 1.9.16 和 1.10.11 之前的 Apache Ant 受到影响。


2. 影响的操作系统及修复版本

  • 银河麒麟高级服务器操作系统 V10 SP2

ant-1.10.8-4.ky10

ant-antlr-1.10.8-4.ky10

ant-apache-bcel-1.10.8-4.ky10

ant-apache-bsf-1.10.8-4.ky10

ant-apache-log4j-1.10.8-4.ky10

ant-apache-oro-1.10.8-4.ky10

ant-apache-regexp-1.10.8-4.ky10

ant-apache-resolver-1.10.8-4.ky10

ant-apache-xalan2-1.10.8-4.ky10

ant-commons-logging-1.10.8-4.ky10

ant-commons-net-1.10.8-4.ky10

ant-help-1.10.8-4.ky10

ant-imageio-1.10.8-4.ky10

ant-javamail-1.10.8-4.ky10

ant-jdepend-1.10.8-4.ky10

ant-jmf-1.10.8-4.ky10

ant-jsch-1.10.8-4.ky10

ant-junit-1.10.8-4.ky10

ant-junit5-1.10.8-4.ky10

ant-lib-1.10.8-4.ky10

ant-swing-1.10.8-4.ky10

ant-testutil-1.10.8-4.ky10

ant-xz-1.10.8-4.ky10


3. 受影响的软件包

  • 银河麒麟高级服务器操作系统 V10 SP2

    • aarch64:ant、ant-antlr、ant-apache-bcel、ant-apache-bsf、ant-apache-log4j、ant-apache-oro、ant-apache-regexp、ant-apache-resolver、ant-apache-xalan2、ant-commons-logging、ant-commons-net、ant-help、ant-imageio、ant-javamail、ant-jdepend、ant-jmf、ant-jsch、ant-junit、ant-junit5、ant-lib、ant-swing、ant-testutil、ant-xz

    • x86_64:ant、ant-antlr、ant-apache-bcel、ant-apache-bsf、ant-apache-log4j、ant-apache-oro、ant-apache-regexp、ant-apache-resolver、ant-apache-xalan2、ant-commons-logging、ant-commons-net、ant-help、ant-imageio、ant-javamail、ant-jdepend、ant-jmf、ant-jsch、ant-junit、ant-junit5、ant-lib、ant-swing、ant-testutil、ant-xz


4. 修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:银河麒麟高级服务器操作系统 V10 SP2

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/

2.配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename


5. 软件包下载地址

  • 银河麒麟高级服务器操作系统 V10 SP2

 ant aarch64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-antlr-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-apache-bcel-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-apache-bsf-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-apache-log4j-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-apache-oro-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-apache-regexp-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-apache-resolver-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-apache-xalan2-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-commons-logging-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-commons-net-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-help-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-imageio-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-javamail-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-jdepend-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-jmf-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-jsch-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-junit-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-junit5-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-lib-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-swing-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-testutil-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/ant-xz-1.10.8-4.ky10.noarch.rpm

 ant x86_64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-antlr-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-apache-bcel-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-apache-bsf-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-apache-log4j-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-apache-oro-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-apache-regexp-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-apache-resolver-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-apache-xalan2-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-commons-logging-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-commons-net-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-help-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-imageio-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-javamail-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-jdepend-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-jmf-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-jsch-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-junit-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-junit5-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-lib-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-swing-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-testutil-1.10.8-4.ky10.noarch.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/ant-xz-1.10.8-4.ky10.noarch.rpm

注:其他相关依赖包请到相同目录下载

 




上一篇: KYSA-202109-1011 下一篇: KYSA-202109-1013

试用

服务

动态

联系