服务支持

loophole

安全补丁公告

当前位置  >  首页  >  服务支持  >  安全补丁公告

公告ID(KYSA-202109-1013

摘要:libexif漏洞 安全等级:中等 公告ID:KYSA-202109-1013 发布日期:2021-09-10 影响CVE:CVE-2020-13113、CVE-2020-13114

详细介绍

1. 修复的CVE信息

  • CVE-2020-13113

    描述:libexif 0.6.22之前版本中存在资源管理错误漏洞,该漏洞源于在EXIF Makernote处理过程中使用了未初始化的内存。攻击者可利用该漏洞造成拒绝服务(崩溃和释放后重用)。

  • CVE-2020-13114

    描述:libexif 0.6.22之前版本中存在安全漏洞,该漏洞源于程序在处理Canon EXIF MakerNote数据时没有限制大小值。攻击者可利用该漏洞使程序消耗大量计算时间来解码EXIF数据,导致服务中断。


2. 影响的操作系统及修复版本

  • 银河麒麟高级服务器操作系统 V10 SP2

libexif-0.6.21-22.ky10

libexif-debugsource-0.6.21-22.ky10

libexif-devel-0.6.21-22.ky10

libexif-help-0.6.21-22.ky10


3. 受影响的软件包

  • 银河麒麟高级服务器操作系统 V10 SP2

aarch64:libexif、libexif-debugsource、libexif-devel、libexif-help

x86_64:libexif、libexif-debugsource、libexif-devel、libexif-help


4. 修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

银河麒麟高级服务器操作系统 V10 SP2

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/

2.配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename


5. 软件包下载地址

  • 银河麒麟高级服务器操作系统 V10 SP2

 libexif aarch64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/libexif-0.6.21-22.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/libexif-debugsource-0.6.21-22.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/libexif-devel-0.6.21-22.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/libexif-help-0.6.21-22.ky10.noarch.rpm 

 libexif x86_64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/libexif-0.6.21-22.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/libexif-debugsource-0.6.21-22.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/libexif-devel-0.6.21-22.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/libexif-help-0.6.21-22.ky10.noarch.rpm

注:其他相关依赖包请到相同目录下载

 


上一篇: KYSA-202109-1012 下一篇: KYSA-202109-1014

试用

服务

动态

联系