安全漏洞

loophole

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202112-0012

摘要:openjdk-8安全漏洞 安全等级:中等 公告ID:KYSA-202112-0012 发布日期:2021-12-27 影响CVE:CVE-2021-35559、CVE-2021-35556、CVE-2021-35603、CVE-2021-35550、CVE-2021-35567、CVE-2021-35564、CVE-2021-35565、CVE-2021-35588、CVE-2021-35561、CVE-2021-35586、CVE-2021-35578

详细介绍

1.修复的CVE

    CVE-2021-35559

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle GraalVM中存在输入验证错误漏洞。该漏洞源于网络系统或产品未对输入的数据进行正确的验证。

    CVE-2021-35556

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition 存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过多种协议访问网络。成功攻击此漏洞可导致拒绝服务。

    CVE-2021-35603

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition 存在输入验证错误漏洞,该漏洞源于JSSE组件的输入验证不当。远程的未经身份验证的攻击者可以利用此漏洞获取敏感信息的访问权。

    CVE-2021-35550

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition 存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过 TLS 进行网络访问以破坏Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致对关键数据的未授权访问或对所有Oracle GraalVM Enterprise Edition 可访问数据的完全访问。

    CVE-2021-35567

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition (组件:Libraries)存在输入验证错误漏洞,该漏洞可导致对关键数据的未授权访问或对所有 Oracle GraalVM Enterprise Edition product 数据的完全访问。

    CVE-2021-35564

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition(组件:Keytool)存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过多种协议访问网络来破坏Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致对Oracle GraalVM Enterprise Edition可访问数据的未授权更新、插入或删除访问。

    CVE-2021-35565

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition 存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过 TLS 进行网络访问。成功攻击此漏洞可导致拒绝服务。

    CVE-2021-35588

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition(组件:Hotspot)存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过多种协议访问网络来破坏Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致拒绝服务。

    CVE-2021-35561

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition(组件:Utility)存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过多种协议访问网络来破坏 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致拒绝服务。

    CVE-2021-35586

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition(组件:ImageIO)存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过多种协议访问网络,从而破坏 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致拒绝服务。

    CVE-2021-35578

    Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE Oracle GraalVM Enterprise Edition(组件:JSSE)存在输入验证错误漏洞,该漏洞允许未经身份验证的攻击者通过 TLS 进行网络访问以破坏 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致拒绝服务。

    

2.影响的操作系统

    银河麒麟桌面操作系统V10 SP1

    

3.修复版本

    软件包:openjdk-8

    1.9.7-1kylin0.2(V10 SP1)

    

4.受影响的软件包

    ·银河麒麟桌面操作系统V10 SP1

    openjdk-8-dbg

    openjdk-8-demo

    openjdk-8-doc

    openjdk-8-jdk

    openjdk-8-jdk-headless

    openjdk-8-jre

    openjdk-8-jre-headless

    openjdk-8-jre-zero

    openjdk-8-source

    

5.修复方法

方法一:配置源进行升级安装

    打开软件包源配置文件,根据仓库地址进行修改。

    4.0.2桌面版本:

    http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2-desktop main restricted universe multiverse

    4.0.2-sp1桌面版本:

    http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp1-desktop main restricted universe multiverse

    4.0.2-sp2桌面版本:

    http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp2-desktop main restricted universe multiverse

    4.0.2-sp3桌面版本:

    http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp3-desktop main restricted universe multiverse

    4.0.2-sp4桌面版本:

    http://archive.kylinos.cn/kylin/KYLIN-ALL 4.0.2sp4-desktop main restricted universe multiverse

    10.0版本:

    http://archive.kylinos.cn/kylin/KYLIN-ALL 10.0 main restricted universe multiverse

    10SP1版本:

    http://archive.kylinos.cn/kylin/KYLIN-ALL 10.1 main restricted universe multiverse

    配置完成后执行更新命令进行升级

    $sudo apt update

方法二:下载安装包进行升级安装

    通过软件包地址下载软件包,使用软件包升级命令根据受影响的组件包列表 升级相关的组件包。

    $dpkg -i Packagelists

    

6.软件包下载地址

银河麒麟操作系统桌面版V10 SP1

X86_64软件包下载地址

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/universe/h/htmldoc/htmldoc-common_1.9.7-1kylin0.2_all.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/universe/h/htmldoc/htmldoc_1.9.7-1kylin0.2_amd64.deb

arm64软件包下载地址

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/universe/h/htmldoc/htmldoc-common_1.9.7-1kylin0.2_all.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/universe/h/htmldoc/htmldoc_1.9.7-1kylin0.2_arm64.deb

mips64el软件包下载地址

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/universe/h/htmldoc/htmldoc-common_1.9.7-1kylin0.2_all.deb

http://archive.kylinos.cn/kylin/KYLIN-ALL/pool/universe/h/htmldoc/htmldoc_1.9.7-1kylin0.2_mips64el.deb


上一篇: KYSA-202112-0011 下一篇: KYSA-202106-1006

试用

服务

动态

联系