安全漏洞

loophole

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202205-1017

公告ID:KYSA-202205-1017 公告摘要:perl-DBI安全漏洞 安全等级:Moderate 发布日期:2022年05月10日 影响CVE:CVE-2014-10402

详细介绍

1. 修复的CVE

·CVE-2014-10402

描述:Perl是Perl社区的一款通用、解释型、动态的跨平台编程语言。Perl 1.643版本存在安全漏洞。该漏洞源于DBD::File驱动程序可以从文件夹中打开文件,而不是通过数据源名称(DSN)中的f_dir属性专门传递的文件。

2. 受影响的软件包

·银河麒麟高级服务器操作系统 V10 SP1

loongarch64架构:

perl-DBI、perl-DBI-help

3. 软件包修复版本

·银河麒麟高级服务器操作系统 V10 SP1

perl-DBI-1.643-2.a.ky10

perl-DBI-help-1.643-2.a.ky10

4. 修复方法

方法一:配置源进行升级安装

1. 打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

银河麒麟高级服务器操作系统 V10 SP1

loongarch64:https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/loongarch64/

2. 配置完成后执行更新命令进行升级,命令如下:

yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:

yum install Packagename

3. 升级完成后是否需要重启服务或操作系统:

·CVE-2014-10402:无需重启操作系统与服务即可使漏洞修复生效。

5. 软件包下载地址

·银河麒麟高级服务器操作系统 V10 SP1

 

perl-DBI(loongarch64)软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/loongarch64/Packages/perl-DBI-1.643-2.a.ky10.loongarch64.rpm

https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/loongarch64/Packages/perl-DBI-help-1.643-2.a.ky10.noarch.rpm

 

注:其他相关依赖包请到相同目录下载

6. 修复验证

使用软件包查询命令,查看相关软件包版本是否与修复版本一致,如果版本一致,则说明修复成功。

sudo rpm -qa | grep Packagename


上一篇: KYSA-202205-1016 下一篇: KYSA-202205-1018

试用

服务

动态

联系