安全漏洞

loophole

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202205-1021

公告ID:KYSA-202205-1021 公告摘要:rubygem-bundler安全漏洞 安全等级:Important 发布日期:2022年05月10日 影响CVE:CVE-2021-43809

详细介绍

1. 修复的CVE

·CVE-2021-43809

描述:Bundler是一个应用软件。通过跟踪和安装所需的确切gem和版本,为Ruby项目提供了一致的环境。Bundler 存在参数注入漏洞,该漏洞源于在使用Gemfile时,如果 Gemfile 包含 gem 条目并使git选项无效,攻击者通过构造特殊的文件内容可以导致恶意命令注入。

2. 受影响的软件包

·银河麒麟高级服务器操作系统 V10 SP2

aarch64架构:

rubygem-bundler、rubygem-bundler-help

x86_64架构:

rubygem-bundler、rubygem-bundler-help

3. 软件包修复版本

·银河麒麟高级服务器操作系统 V10 SP2

rubygem-bundler-2.2.33-1.ky10

rubygem-bundler-help-2.2.33-1.ky10

4. 修复方法

方法一:配置源进行升级安装

1. 打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

银河麒麟高级服务器操作系统 V10 SP2

aarch64:https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/aarch64/

x86_64:https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/x86_64/

2. 配置完成后执行更新命令进行升级,命令如下:

yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:

yum install Packagename

3. 升级完成后是否需要重启服务或操作系统:

·CVE-2021-43809:无需重启操作系统与服务即可使漏洞修复生效。

5. 软件包下载地址

·银河麒麟高级服务器操作系统 V10 SP2

 

rubygem-bundler(aarch64)软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/rubygem-bundler-2.2.33-1.ky10.noarch.rpm

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/rubygem-bundler-help-2.2.33-1.ky10.noarch.rpm

 

rubygem-bundler(x86_64)软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/rubygem-bundler-2.2.33-1.ky10.noarch.rpm

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/rubygem-bundler-help-2.2.33-1.ky10.noarch.rpm

 

注:其他相关依赖包请到相同目录下载

6. 修复验证

使用软件包查询命令,查看相关软件包版本是否与修复版本一致,如果版本一致,则说明修复成功。

sudo rpm -qa | grep Packagename


上一篇: KYSA-202202-0009 下一篇: KYSA-202205-1022

试用

服务

动态

联系