安全漏洞

loophole

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202303-1059

公告ID:KYSA-202303-1059 公告摘要:rsync安全漏洞 等级:Important 发布日期:2023-03-14

详细介绍

1.修复的CVE ·CVE-2018-25032 描述:zlib是美国Mark Adler个人开发者的一个通用的数据压缩库。zlib 1.2.11 版本存在缓冲区错误漏洞,该漏洞源于如果输入有很多远匹配,压缩时可能出现内存损坏。 ·CVE-2022-29154 描述:rsync是Wayne Davison个人开发者的一个提供快速增量文件传输的开源实用程序。rsync 3.2.5之前版本存在安全漏洞,该漏洞源于rsync 客户端对文件名的验证不足。 2.受影响的软件包 ·银河麒麟高级服务器操作系统(兼容版) V10 ·aarch64架构: rsync、rsync-daemon ·x86_64架构: rsync、rsync-daemon 3.软件包修复版本 ·银河麒麟高级服务器操作系统(兼容版) V10 (aarch64、x86_64) rsync-3.1.3-19.el8或以上版本 rsync-daemon-3.1.3-19.el8或以上版本 4.修复方法 方法一:配置源进行升级安装 1.打开软件包源配置文件,根据仓库地址进行修改。 仓库源地址: 银河麒麟高级服务器操作系统(兼容版) V10 aarch64:https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/PowerTools-updates/aarch64/ x86_64:https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/PowerTools-updates/x86_64/ 2.配置完成后执行更新命令进行升级,命令如下: yum update Packagename 方法二:下载安装包进行升级安装 通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包 列表进行升级安装, 命令如下: yum install Packagename 3.升级完成后是否需要重启服务或操作系统: CVE-2018-25032:无需重启操作系统与服务即可使漏洞修复生效。 CVE-2022-29154:无需重启操作系统与服务即可使漏洞修复生效。 5.软件包下载地址 ·银河麒麟高级服务器操作系统(兼容版) V10 rsync(aarch64)软件包下载地址: https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/AppStream-updates/aarch64/Packages/rsync-3.1.3-19.el8.aarch64.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/BaseOS-updates/aarch64/Packages/rsync-3.1.3-19.el8.aarch64.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/PowerTools-updates/aarch64/Packages/rsync-3.1.3-19.el8.aarch64.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/AppStream-updates/aarch64/Packages/rsync-daemon-3.1.3-19.el8.noarch.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/BaseOS-updates/aarch64/Packages/rsync-daemon-3.1.3-19.el8.noarch.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/PowerTools-updates/aarch64/Packages/rsync-daemon-3.1.3-19.el8.noarch.rpm rsync(x86_64)软件包下载地址: https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/AppStream-updates/x86_64/Packages/rsync-3.1.3-19.el8.x86_64.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/BaseOS-updates/x86_64/Packages/rsync-3.1.3-19.el8.x86_64.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/PowerTools-updates/x86_64/Packages/rsync-3.1.3-19.el8.x86_64.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/AppStream-updates/x86_64/Packages/rsync-daemon-3.1.3-19.el8.noarch.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/BaseOS-updates/x86_64/Packages/rsync-daemon-3.1.3-19.el8.noarch.rpm https://update.cs2c.com.cn/NS/V10/8U2/os/adv/lic/PowerTools-updates/x86_64/Packages/rsync-daemon-3.1.3-19.el8.noarch.rpm 注:其他相关依赖包请到相同目录下载 6.修复验证 使用软件包查询命令,查看相关软件包版本是否与修复版本一致,如果版本一致,则说明修复成功。 sudo rpm -qa | grep Packagename
上一篇: KYSA-202303-1058 下一篇: KYSA-202303-1060

试用

服务

动态

联系