安全漏洞

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202407-1012

公告ID:KYSA-202407-1012 公告摘要:telnet安全漏洞 等级:Important 发布日期:2024-07-02

详细介绍

1.修复的CVE ·CVE-2022-39028 描述:GNU Inetutils是GNU社区的一组常见的网络程序。 GNU Inetutils 2.3版本及之前版本、MIT krb5-appl 1.0.3版本及之前版本存在安全漏洞,该漏洞源于取消引用 NULL 指针,导致telnetd 应用程序崩溃。 ·CVE-2022-39028 描述:GNU Inetutils是GNU社区的一组常见的网络程序。 GNU Inetutils 2.3版本及之前版本、MIT krb5-appl 1.0.3版本及之前版本存在安全漏洞,该漏洞源于取消引用 NULL 指针,导致telnetd 应用程序崩溃。 2.受影响的软件包 ·银河麒麟高级服务器操作系统 V10 HPC ·aarch64架构: telnet-help、telnet ·x86_64架构: telnet-help、telnet 3.软件包修复版本 ·银河麒麟高级服务器操作系统 V10 HPC (aarch64、x86_64) telnet-help-0.17-79.ky10h或以上版本 telnet-0.17-79.ky10h或以上版本 4.修复方法 方法一:配置源进行升级安装 1.打开软件包源配置文件,根据仓库地址进行修改。 仓库源地址: 银河麒麟高级服务器操作系统 V10 HPC aarch64:https://update.cs2c.com.cn/NS/V10/HPC/os/adv/lic/updates/aarch64/ x86_64:https://update.cs2c.com.cn/NS/V10/HPC/os/adv/lic/updates/x86_64/ 2.配置完成后执行更新命令进行升级,命令如下: yum update Packagename 方法二:下载安装包进行升级安装 通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包 列表进行升级安装, 命令如下: yum install Packagename 3.升级完成后是否需要重启服务或操作系统: CVE-2022-39028:需要重启 telnet 以使漏洞修复生效。 CVE-2022-39028:需要重启 telnet 以使漏洞修复生效。 5.软件包下载地址 ·银河麒麟高级服务器操作系统 V10 HPC telnet(aarch64)软件包下载地址: https://update.cs2c.com.cn/NS/V10/HPC/os/adv/lic/updates/aarch64/Packages/telnet-help-0.17-79.ky10h.aarch64.rpm https://update.cs2c.com.cn/NS/V10/HPC/os/adv/lic/updates/aarch64/Packages/telnet-0.17-79.ky10h.aarch64.rpm telnet(x86_64)软件包下载地址: https://update.cs2c.com.cn/NS/V10/HPC/os/adv/lic/updates/x86_64/Packages/telnet-help-0.17-79.ky10h.x86_64.rpm https://update.cs2c.com.cn/NS/V10/HPC/os/adv/lic/updates/x86_64/Packages/telnet-0.17-79.ky10h.x86_64.rpm 注:其他相关依赖包请到相同目录下载 6.修复验证 使用软件包查询命令,查看相关软件包版本是否与修复版本一致,如果版本一致,则说明修复成功。 sudo rpm -qa | grep Packagename
上一篇: KYSA-202407-1011 下一篇: KYSA-202311-0079

试用

服务

动态

联系