安全漏洞

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202311-0071

公告ID:KYSA-202311-0071 公告摘要:perl安全漏洞 等级:重要 发布日期:2024-07-08

详细介绍

1. 修复的CVE CVE-2022-48522 Perl是一款通用、解释型、动态的跨平台编程语言。 Perl 5.34.0版本存在安全漏洞,该漏洞源于函数S_find_uninit_var存在堆栈崩溃问题,攻击者可利用该漏洞进行远程代码执行(RCE)或本地权限升级。 CVE-2023-47038 Perl是一款通用、解释型、动态的跨平台编程语言。Perl 5.30.0 到 5.38.0版本存在缓冲区错误漏洞,该漏洞源于当 Perl 编译精心设计的正则表达式时,允许攻击者在堆分配的缓冲区中控制字节缓冲区溢出。 2. 受影响的操作系统及软件包 ·银河麒麟桌面操作系统V10 SP1 2403 x86_64 架构: libperl5.30、perl-base、perl-debug、perl-modules-5.30、perl arm64 架构: libperl5.30、perl-base、perl-debug、perl-modules-5.30、perl mips64el 架构: libperl5.30、perl-base、perl-debug、perl-modules-5.30、perl loongarch64 架构: libperl5.30、perl-base、perl-debug、perl-modules-5.30、perl 3. 软件包修复版本 ·银河麒麟桌面操作系统V10 SP1 2403 5.30.0-9kylin0.5k0.1 4. 修复方法 方法一:升级安装 执行更新命令进行升级 $sudo apt update $sudo apt install perl 方法二:下载软件包进行升级安装 如系统版本为2403,可通过软件包下载方法下载软件包,使用软件包升级命令根据受影响的软件包列表升级相关的组件包。 $sudo apt-get install /Path1/Package1 /Path2/Package2 /Path3/Package3…… 5. 软件包下载方法 银河麒麟桌面操作系统V10 SP1 2403 执行如下命令进行软件包下载: $sudo apt clean $sudo apt-get --download-only --fix-broken -y install perl 下载后文件保存路径:/var/cache/apt/archives 6. 修复验证 使用软件包查询命令,查看相关的软件包版本大于或等于修复版本则成功修复。 $sudo dpkg -l |grep Package 注:Package为软件包包名。
上一篇: KYSA-202311-0079 下一篇: KYSA-202311-0072

试用

服务

动态

联系