安全漏洞

loophole

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202112-1009

摘要:varnish漏洞 安全等级:重要 公告ID:KYSA-202112-1009 发布日期:2021-12-03 影响CVE:CVE-2021-36740

详细介绍

1. 修复的CVE信息

  • CVE-2021-36740

    描述:Varnish Cache是一套反向网站缓存服务器。

    Varnish Enterprise 存在安全漏洞,该漏洞源于启用 HTTP/2 的 Varnish 缓存允许通过 POST 请求的大型 Content-Length 标头进行请求走私和VCL授权绕过。


2. 影响的操作系统及修复版本

  • 银河麒麟高级服务器操作系统 V10 SP1

varnish-6.0.0-6.ky10

varnish-devel-6.0.0-6.ky10

varnish-help-6.0.0-6.ky10


3. 受影响的软件包

  • 银河麒麟高级服务器操作系统 V10 SP1

aarch64:varnish、varnish-devel、varnish-help

x86_64:varnish、varnish-devel、varnish-help


4. 修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

银河麒麟高级服务器操作系统 V10 SP1

aarch64:http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/

x86_64:http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/

2.配置完成后执行更新命令进行升级,命令如下:yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:yum install Packagename


5. 软件包下载地址

  • 银河麒麟高级服务器操作系统 V10 SP1

 varnish aarch64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/Packages/varnish-6.0.0-6.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/Packages/varnish-devel-6.0.0-6.ky10.aarch64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/Packages/varnish-help-6.0.0-6.ky10.noarch.rpm

 varnish x86_64软件包下载地址:

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/Packages/varnish-6.0.0-6.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/Packages/varnish-devel-6.0.0-6.ky10.x86_64.rpm

http://update.cs2c.com.cn:8080/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/Packages/varnish-help-6.0.0-6.ky10.noarch.rpm

注:其他相关依赖包请到相同目录下载

 



上一篇: KYSA-202112-1008 下一篇: KYSA-202112-1010

试用

服务

动态

联系