安全漏洞

loophole

安全漏洞补丁公告

当前位置  >  首页  >  服务支持  >  安全漏洞  >  安全漏洞补丁公告

公告ID(KYSA-202112-1042

摘要:mod_security漏洞 安全等级:重要 发布日期:2021-12-31 影响CVE:CVE-2021-42717

详细介绍

1.修复的CVE

CVE-2021-42717

描述:ModSecurity是一个入侵检测、阻止的引擎可以作为Apache Web服务器的一个模块或单独的应用程序来运行,为增强Web应用程序的安全性和保护Web应用程序避免遭受来自已知与未知的攻击。ModSecurity存在安全漏洞,该漏洞源于 ModSecurity 错误处理了过度嵌套的 JSON 对象。精心制作的具有数万层嵌套深度的 JSON 对象可能会导致 Web 服务器无法为合法请求提供服务。即使是中等大小(例如 300KB)的 HTTP 请求也可能占用一个有限的 NGINX 工作进程数分钟,并消耗机器上几乎所有可用的 CPU。


2.影响的操作系统及修复版本

银河麒麟高级服务器操作系统 V10 SP2

debug/mod_security-debuginfo-2.9.5-1.ky10

mod_security-2.9.5-1.ky10

·银河麒麟高级服务器操作系统 V10 SP1

mod_security-2.9.5-1.ky10


3.受影响的软件包

银河麒麟高级服务器操作系统 V10 SP2

aarch64:debug/mod_security-debuginfo、mod_security、

x86_64:debug/mod_security-debuginfo、mod_security、

银河麒麟高级服务器操作系统 V10 SP1

aarch64:mod_security、

mips64el:mod_security、

x86_64:mod_security、


4.修复方法

方法一:配置源进行升级安装

1.打开软件包源配置文件,根据仓库地址进行修改。

仓库源地址:

银河麒麟高级服务器操作系统 V10 SP2

aarch64:https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/aarch64/

x86_64:https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/x86_64/

银河麒麟高级服务器操作系统 V10 SP1

aarch64:https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/

mips64el:https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/mips64el/

x86_64:https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/

2.配置完成后执行更新命令进行升级,命令如下:

yum update Packagename

方法二:下载安装包进行升级安装

通过软件包地址下载软件包,使用软件包升级命令根据受影响的软件包列表进行升级安装,命令如下:

yum install Packagename


5.软件包下载地址:

银河麒麟高级服务器操作系统 V10 SP2

 mod_security aarch64软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/debug/mod_security-debuginfo-2.9.5-1.ky10.aarch64.rpm

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/aarch64/Packages/mod_security-2.9.5-1.ky10.aarch64.rpm

 mod_security x86_64软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/debug/mod_security-debuginfo-2.9.5-1.ky10.x86_64.rpm

https://update.cs2c.com.cn/NS/V10/V10SP2/os/adv/lic/updates/x86_64/Packages/mod_security-2.9.5-1.ky10.x86_64.rpm

 

银河麒麟高级服务器操作系统 V10 SP1

 mod_security aarch64软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/aarch64/Packages/mod_security-2.9.5-1.ky10.aarch64.rpm

 mod_security mips64el软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/mips64el/Packages/mod_security-2.9.5-1.ky10.mips64el.rpm

 mod_security x86_64软件包下载地址:

https://update.cs2c.com.cn/NS/V10/V10SP1.1/os/adv/lic/updates/x86_64/Packages/mod_security-2.9.5-1.ky10.x86_64.rpm 

注:其他相关依赖包请到相同目录下载


上一篇: KYSA-202112-1041 下一篇: KYSA-202112-1043

试用

服务

动态

联系