服务支持

update

系统更新

当前位置  >  首页  >  服务支持  >  系统更新

更新ID(KYUA-202201-1015

更新简述:
使用lio+target_core_user进行iscsi target 模拟时候login崩溃问题
影响操作系统版本:
银河麒麟高级服务器操作系统V10(SP1) 银河麒麟高级服务器操作系统V10(SP2) 内核版本 17系列版本内核:17.0及以上版本都存在该问题; 20系列版本内核:20.0及以上版本都存在该问题; 21系列版本内核:21.0及以上版本都存在该问题; 22系列版本内核:22.0及以上版本都存在该问题; 23系列版本内核:23.0~23.14版本都存在该问题,23.15及以上版本解决该问题; 24系列版本内核:24.0及以上版本都存在该问题; 25系列版本内核:25.0~25.5版本都存在该问题,25.6及以上版本解决该问题; 26系列版本内核:26.0及以上版本都存在该问题; 27系列版本内核:27.0及以上版本解决该问题;
更新类型:
问题修复
发布时间:
2021-12-27

详细介绍

1.复现步骤 

1. 搭建ceph,并使用lio进行配置。

2. 在其他客户端节点使用iscsiadm扫描卷,然后发现服务器重启了,kdump中采集的内核日志信息有如下警告和oops打印信息:

undefined

 

undefined

 

undefined

 

2.原因简述

page的初始化存在问题,这个问题是linux社区内核迭代过程中引入的,如社区4.19系列版本就存在这个问题,目前麒麟内核4.19.90-23.15.v2101和社区均已修复这个问题。


3.解决方案/修复/更新方法

需要安装以下必要内核rpm包升级内核到4.19.90-23.15.v2101或者4.19.90-23.15.v2101以上版本。

下面以安装4.19.90-23.15.v2101内核版本为例:

kernel-4.19.90-23.15.v2101.ky10.*.rpm

kernel-core-4.19.90-23.15.v2101.ky10.*.rpm

kernel-devel-4.19.90-23.15.v2101.ky10.*.rpm

kernel-headers-4.19.90-23.15.v2101.ky10.*.rpm

kernel-modules-4.19.90-23.15.v2101.ky10.*.rpm

kernel-modules-extra-4.19.90-23.15.v2101.ky10.*.rpm

kernel-modules-internal-4.19.90-23.15.v2101.ky10.*.rpm

通过以下命令进行升级安装:

rpm -ivh kernel-4.19* kernel-core* kernel-modules*

rpm -Uvh kernel-devel* kernel-headers*

安装完后,需要重启机器生效。

上一篇: KYUA-202201-1014 下一篇: KYUA-202201-1016

试用

服务

动态

联系