服务支持

update

系统更新

当前位置  >  首页  >  服务支持  >  系统更新

更新ID(KYUA-202201-1017

更新简述:
鲲鹏服务器上虚拟机启动失败问题
影响操作系统版本:
银河麒麟高级服务器操作系统(鲲鹏版)V10(SP1) 银河麒麟高级服务器操作系统(鲲鹏版)V10(SP2) 影响内核版本: 23系列版本内核:23.16~23.17版本都存在该问题,23.18及以上版本解决该问题; 25系列版本内核:25.7~25.8版本都存在该问题,25.9及以上版本解决该问题;
更新类型:
问题修复
发布时间:
2021-12-24

详细介绍

1.复现步骤 

软硬件信息:

机型: 超强K620-M1

处理器:鲲鹏920

内存:512G

整机类型/架构:服务器

系统版本:Kylin-Server-10-SP1-Release-Build04-20200711-arm64

内核版本:4.19.90-17.ky10.aarch64

 

复现步骤:

升级内核到4.19.90-23.16.ky10.aarch64后,服务器云平台创建虚拟机失败,现象必现,报错信息如下所示:

undefined

 

2.原因简述

因md驱动的io inflight统计缺陷导致虚拟机不能正常启动使用


3.解决方案/修复/更新方法

需要安装以下必要内核rpm包升级内核到4.19.90-23.18.v2101或者4.19.90-23.18.v2101以上版本。

下面以安装4.19.90-23.18.v2101内核版本为例:

kernel-4.19.90-23.18.v2101.ky10.aarch64.rpm

kernel-core-4.19.90-23.18.v2101.ky10.aarch64.rpm

kernel-devel-4.19.90-23.18.v2101.ky10.aarch64.rpm

kernel-headers-4.19.90-23.18.v2101.ky10.aarch64.rpm

kernel-modules-4.19.90-23.18.v2101.ky10.aarch64.rpm

kernel-modules-extra-4.19.90-23.18.v2101.ky10.aarch64.rpm

kernel-modules-internal-4.19.90-23.18.v2101.ky10.aarch64.rpm

 

通过以下命令进行升级安装:

rpm -ivh kernel-4.19* kernel-core* kernel-modules*

rpm -Uvh kernel-devel* kernel-headers*

 

安装完后,需要重启机器生效。


上一篇: KYUA-202201-1016 下一篇: KYUA-202201-1018

试用

服务

动态

联系