服务支持

update

系统更新

当前位置  >  首页  >  服务支持  >  系统更新

更新ID(KYUA-202201-1002

更新简述:
vnc连接到服务器,点击菜单图标或终端输入命令,图形工具日志(gnome-logs)打不开。
影响操作系统版本:
银河麒麟高级服务器操作系统(飞腾版)V10(SP1)0518 银河麒麟高级服务器操作系统(鲲鹏版)V10(SP1)0518 银河麒麟高级服务器操作系统(兆芯版)V10(SP1)0518 银河麒麟高级服务器操作系统(海光版)V10(SP1)0518 银河麒麟高级服务器操作系统(飞腾版)V10(SP2)0524 银河麒麟高级服务器操作系统(鲲鹏版)V10(SP2)0524 银河麒麟高级服务器操作系统(兆芯版)V10(SP2)0524 银河麒麟高级服务器操作系统(海光版)V10(SP2)0524
更新类型:
问题修复
发布时间:
2021-12-23

详细介绍

1.复现步骤 

复现方法:

1. ssh开启vnc服务器。

2. VNC连接到服务器。

3. 开始菜单-系统工具-日志。

 

结果:

1、点击【日志】无反应

undefined

 

2.原因简述

原因:由于在ssh中开启vncserver服务,vncserver继承了ssh的环境变量。当启动日志应用时,由于提权失败,就会导致日志图形启动失败,出现(gnome-logs:30856): Gtk-WARNING **: 14:51:14.537: cannot open display: :0.0 警告,


3.解决方案/修复/更新方法

解决方案:日志(gnome-logs)通过给予程序环境变量xhost +的方式,允许跨用户启动。

安装新版本:rpm -Uvh gnome-logs-3.32.1-1.p08(或更高版本)或yum update gnome-logs。

程序成功升级后立即生效。


上一篇: KYUA-202201-1001 下一篇: KYUA-202201-1003

试用

服务

动态

联系